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Introduction 
SharePoint 2010 is the core server component of the Microsoft Office System.  The Office System 
includes many of Microsoft’s products such as SharePoint Server, SharePoint Foundation, Word, Excel, 
PowerPoint, Lync (previously Live Communications Server), and SQL server.  SharePoint 2010 is a 
business collaboration platform used to set up web sites across which information is shared.  SharePoint 
2010 allows people to work together more efficiently, access information faster, create solutions to 
respond to business needs and increase productivity. 

Sites 
A site collection is a group of related sites that allows for sharing content as well as the sharing of 

certain configuration settings.  A top-level site is automatically created in a site collection and then sub-

sites can be created below the top-level site.  Top-level sites are commonly referred to as the ‘parent’ 

site and sub-sites are the ‘child’ sites.  When a sub-site is created, it automatically inherits (uses) the 

same permission levels as the top-level site.   

Users can choose from many types of site templates when creating a site.  Most companies create sub-

sites using the Team Site template because the template is designed to promote collaboration and 

information sharing.  Throughout this training, the term ‘sub-site’ refers to a Team site.   

Examine the Layout  
Out- of- the box (OOTB) Team sites contain the following lists: 

 Document Libraries:  Shared Documents, Site Assets, Site Pages 

 Announcements list 

 Calendar 

 Tasks list 

 Team Discussion list 

 Links list 
 

The only items displayed on the home page are the Welcome message, the Shared Documents library, a 

picture, the Getting Started links, and the Quick Launch links.  The picture below identifies the areas of 

the OOTB Home page.   
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Item Description 

1    Ribbon The ribbon refers to a page-specific menu bar at the top of the page. The content of 
the ribbon changes depending on the type of component the user has highlighted.   

2    User Menu The User Menu in the upper right of the screen provides the User access links to My 
Sites, My Profile, and My Settings specific to the Users login. 

3    Page Breadcrumb Global navigation that displays on all pages.  User can navigate backward in the site by 
clicking any displayed level in the breadcrumb trail. 

4    Search Search allows users to search all of the content on the site. 

5    Top Link Navigation Contains the global navigation links for the site.  Similar to Quick Launch sidebar.  Users 
can add additional links (external URLs, other site pages) 

6  Quick Launch Full Control users can modify the links that show in the Quick Launch.   

 

1 Ribbon 2 User Menu 

3 Page Bread crumb 

4 Search 5 Top Navigation 

6 Quick Launch 
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Change the Site Name 
Full Control users have the ability to change the name of a site.  The URL name cannot be changed when 

a site is created, but the site name can be changed.  When a site is created with a condensed name (to 

save URL character space), it is easy to rename it so the appropriate title displays at the top of the page. 

1. Click Site Actions then Site Settings  >  
2. Under the Look and Feel heading, click the ‘Title, description and icon’ link. 

 
3. Title and Description:   

 Title:  Enter the new name for the site 

 Description:  optional 

 

4. Click OK 

Update the Theme 
SharePoint makes it easy for Full Control users to customize the site layout and neutral color scheme 

and apply their organization’s branding.  SharePoint 2010 Foundations allows for changes to the theme 

(see step 4 below), but Foundation users cannot customize or preview the theme.  Foundation users can 

customize a theme by uploading an Office PowerPoint that uses a theme.     

1. Click Site Actions then Access all settings for this site 
2. Under the Look and Feel heading, select  

 Inherit Theme:  Default is selected 
3. Default Theme:  Default is (no theme) 

 Click on each theme to view the color palette 

 

Note:  Steps 5 - 8 do not pertain to Foundation users. 

4. Customize Theme: Users can change the heading and body font and select one or multiple 
colors to replace with their company’s branding. 
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5. Preview Theme: Click Preview to view the modified theme.   

 
 

 
Note: After viewing the Preview window, click X to close it. 

 
6. Apply Theme:  Default is Apply the selected theme to this site only 

 To save the selected theme, click Apply 

 A processing message displays and theme is changed 

 

Update the Site Icon 
Full Control users can update the site icon with a picture, or the organization’s logo. 

1. Upload the logo to a library, click on the picture, copy the URL 

 SharePoint recommends a logo size of 60 x 60 pixels.  
2. Click Site Actions then Site Settings 

  >   

3. The Site Settings window opens 
4. Under the Look and Feel heading, click the Title, description and icon link 

  
5. Paste the URL location of the image in the URL box 
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 Providing a description is optional, but recommended, as the description displays text if 
the picture does not display properly, and provides information for vision impaired 
users who will hear the description is they use a screen reader accessibility tool. 

 
 

6. Click OK 

Manage the Quick Launch 

Quick Launch is the vertical area on the left side of the page that contains 

links.  The links shown in the Quick Launch provide users quick access to 

content stored on that site.  SharePoint arranges each link under its list type 

heading.  The Quick Launch links displayed on the top level site will be 

different from the links shown on a sub-site because the information is 

stored on a different site.   

Full Control users can configure the Quick Launch the following ways: 

 Add and Remove Links 

 Change the order of Headings and Links 

 Rename the Headings and Links  

 Add new Headings and Links 

 Delete existing Headings and Links 
 

Adding and Removing Lists from the Quick Launch 

When a Full Control user creates a list, the default setting displays the list’s link on the Quick Launch.  

Sometimes users do not want a list to display on the Quick Launch.   

Note: These instructions do not apply for SharePoint 2010 Foundations users (see Foundations Quick 

Launch) 

 Go to the list and select List Settings 

 Click List Tools > List tab  

 Under the General Settings heading, click the Title, description and navigation link 

 
 The Navigation dialog displays the message:  Display this list on the Quick Launch?   

 Click Yes to display the link 

 Click No to remove link 
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 Click Save 
 

Change the Order of Headings and Links  

Full Control users can change the order of Headings and Links displayed in the Quick Launch. 

1. Navigate to the site 
2. Click Site Actions then Site Settings 

  >  

3. Under the Look and Feel heading, click Navigation   
4. Scroll down to Navigation Editing and Sorting and select a heading or link 
5. Click Move Up or Move Down to move the heading and its links to a new location 

 

6. Click OK 

Rename the Headings and Links 

Full Control users can rename the Headings and Links displayed in the Quick Launch. 

1. Navigate to the site 
2. Click Site Actions then Site Settings 

  >  

3. Under the Look and Feel heading, click Navigation   
4. Scroll down to Navigation Editing and Sorting, select a heading or link 

5. Click Edit   
6. Enter the new title in the Title field 
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7. The URL for the Library is shown below the title. Make sure you are changing the title on the 
correct Library before clicking OK. 

 
8. Click OK to save the change. 

 

Add New Headings and Links 

Full Control users can add new headings and links to the Quick Launch.  For example, a user could add 

the link for a wiki page or external website, and the link can be configured to open in a new window.   

1. Navigate to the site 
2. Click Site Actions then Site Settings 

  >  

3. Under the Look and Feel heading, click Navigation   
4. Scroll down to Navigation Editing and Sorting, click Add Heading or Add Link 
5. Enter name to display in the Title page 
6. Paste or type the URL in the URL field 
7. Check the box to open the URL in a new window 

 

8. The new heading is added to the bottom of the Navigation area. 
9. Click Move Up  to rearrange the order of the link in relation to other links 
10. Click OK  

Delete Existing Headings and Links 

Full Control users can delete headings and links from the Quick Launch. 

1. Navigate to the site 
2. Click Site Actions then Site Settings 

  >  

3. Under the Look and Feel heading, click Navigation   
4. Scroll down to Navigation Editing and Sorting 
5. Select the heading and click Delete 
6. Click OK 
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SharePoint 2010 Foundation Quick Launch 
These instructions are for SharePoint 2010 Foundation Full Control users.   

Adding and Removing Lists from the Quick Launch 

1. Go to the list 
2. Click List Tools > List tab>List Settings 
3. Under the General Settings heading, click Title, description and navigation 

  
4. The Navigation dialog box inquires:  Display this list on the Quick Launch?   

 
 To display the list on the Quick Launch, click Yes 

 Click No to remove link 
5. Click Save 

Change Order of Headings and Links 

SharePoint 2010 Foundation Full Control users can change the order for headings and links. 

1. Click Site Actions then Site Settings 

 >  

Under the Look and Feel heading, click Quick Launch  

2. Click Change Order   
3. Arrange the order 

 

1. Click OK 

Add New Headings and Links 

SharePoint 2010 Foundation Full Control users can add new headings and links. 

1. Click Site Actions then Site Settings 

  >  

2. Under the Look and Feel heading, click Quick Launch  
3. Click New Navigation Link or New Heading 
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4. Enter the URL in the web address field and add a description (title for the link) 

 Select the heading where the link will display  

 
 

5. Click OK 

Rename the Headings and Links 

Foundation Full Control users can rename the Headings and Links displayed in the Quick Launch. 

1. Click Site Actions then Site Settings 

 >  

Under the Look and Feel heading, click Quick Launch  

2. Click the edit icon next to heading or link 

 
3. Enter new name, click OK 

 

Delete Existing Headings  

Foundation Full Control users can delete existing headings from the Quick Launch.   

1. Click Site Actions then Site Settings 

 >  

2. Under the Look and Feel heading, click Quick Launch  
3. Click the edit icon next to heading 
4. After the dialog box opens, check to make sure this is the link you want to delete before clicking 

Delete 



              

Page 14 of 63 
 

 Full Control User Training 
 

 

Note: SharePoint 2010 Foundation users will receive this message:  

All the links displayed under the heading will be deleted.   

5. Before clicking OK, move the links under other headings (if applicable). 
SharePoint 2010 Standard and Server versions do not delete the links under a heading and 

therefore will not see this message. 

 

 

6. Heading is removed from Quick Launch 

Create a Sub-site 
Full Control users have the ability to create sub-sites.   

1. Click Site Actions then New Site 

,  

2. Filter By: click Site 
3. Select Team Site 
4. Enter site name (Ex…Portal Training) in the Title field 
5. Enter site name (no spaces) in the URL name field 
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Note:  When creating a site, do not add spaces within the URL name because this creates a long 

URL.  SharePoint has a restrictive length of 255 characters for the URL address.  After the site is 

created, change the site name and add spaces where needed (see Change Site Name).   

6. Click More Options 
7. Scroll down to Permissions 

 Default is ‘Use same permissions as parent site’ 

 For unique (different) permissions, choose ‘Use unique permissions’ 
8. Navigation Inheritance:  Default is No 

 The top link section will show the name of the site created.   

 In the example below, the red box shows the top link section. 
 

 

9. Processing window displays while the site is being created. 

 
 

10. When the processing is complete the site has been created 

Create a Site Template 
Full Control users can create a site template from a Team site and add it to the site collection gallery.   

1. Click Site Actions then Site Settings  

 >  

2. Under the Site Actions heading, click Save site as template  
3. File name:  Enter the name that will be used to save the template 
4. Template Name:  Enter the name for the template 
5. Template description:  Optional 
6. Include Content:  Default is unchecked 
7. Click OK 
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8. The processing message displays while processing us underway. 

 
 

9. Operation Completed Successfully message displays:   

  

10. Click OK 
11. The Site Template is created.   

View All Site Templates 

All Site Templates are stored in a Gallery on the parent site (main Site Collection).  To view all templates 

created follow the steps below: 

1. Click Site Actions then Site Settings  

 >  

2. Under the Galleries section heading, click Solutions   
3. Solutions shows the created site templates 

 

Use a Site Template to Create a Site  
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1. Click Site Actions then New Site 

,  

2. Filter By: Blank & Custom>Portal Training   
Note: Blank & Custom is the fastest method to create a site using template 

3. Title:  Enter site name (Ex…Human Resources) 
4. URL name:  enter site name (Ex…HR) 
5. Click Create or More Options  (depends on requirements) 

 

Delete a Sub-site 
Full Control users should navigate to the sub-site and verify that the correct sub-site is selected before 

deleting the site.   

1. Click Site Actions then New Site 

,  

2. Under the Site Actions heading, click Delete this site  
3. Warning message displays for the site you are trying to delete 

 If it is the correct site, click Delete  

 Click Cancel if the wrong site 
4. Confirmation message displays.  

 
5. Click OK 
6. Processing message displays while the site is being deleted. 

 
 

7. Delete completion message displays when the deletion is completed. 
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8. Click on Go back to site to navigate back to the parent site 
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Practice Activities 
Before continuing the training, practice what was covered in the Sites section by completing the practice 

activities.   

Practice:  Create a sub-site  

Refer to Table of Contents        Time:  15 min 

1. Go to the Training Sandbox site and create a sub-site  

 Name:  Use your initials and last name   Ex: JADoe 
2. Give the site a new name  

 Change the site name to your first and last name  Ex:  Jane Doe 
 

Practice Notes: 

 

 

 

Practice:  Create a site template  

Refer to Table of Contents        Time:  15 min 

1. Go to the site created in Practice 1 
2. Create a site template 
3. Create a new site using the site template 

 
Practice Notes: 

 

 

 

Practice:  Update the Theme 

Refer to Table of Contents        Time:  15 min 

1. Go to the site created using a site template (Practice 2) 
2. Change the theme 
3. Change the site icon 

 

Practice Notes: 
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Practice:  Change order of Quick Launch links   

Refer to Table of Contents        Time:  5 min 

1. Go to the site created using a site template (Practice 2) 
2. Change the order of the Quick Launch links 

 
Practice Notes: 
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Site Security 
When a SharePoint site is created, three SharePoint security groups are automatically created for the 

site: Visitors, Members, and Owners.  The table below identifies permission levels and user actions.   

Site Group Permission Level Users can… 

Site Name Visitors Read View pages, browse libraries and list items, read 
and download lists (document, calendars), email 
links, view properties  

Site Name Members Contribute Read, add, update, and delete items (folders, 
events, documents) in the existing lists and 
document libraries 
Also includes: 

- Delete versions of documents 
- Edit personal user information 
- Manage personal views of data 
- Add/Remove/Update personal web parts 

Site Name Owners Full Control All permissions 
Also includes: 

- Approve permissions 
- Manage lists 
- Add and customize pages 
- Apply themes and borders 
- Apply style sheets 

 

Create a User Group 
User groups are created when a site is created (see User Groups) and additional groups can be added 

that matches the organization need.  Full Control users can create a user group.   

1. Click Site Actions then Site Permissions 

 ,  

2. Click Create Group  
3. Name and About Me Description:  Enter a name for the Group that is descriptive of the group 

 

4. Owner:  The name of the user automatically shows in this field 

 Only one user name can be added to this field 
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Note:  A SharePoint Group can be added instead of a user name.   

5. Group Settings:  Group Members and Group Owner are default 

 

Note:  Select Group Members for the second setting of this section if all members in the group 

have the authority to add and remove members of the group.   

6. Membership Requests:  Default is shown  

 

7. Give Group Permission to this Site:  Choose the permission level, click Create 

 

Change Group Permissions 
Full Control users can change group permissions if the user is added as the owner of the group. 

1. Click Site Actions then Site Permissions  

 ,  

2. Put a check next to group, click Edit User Permissions 
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3. Under Choose Permissions section, change the permission level, click OK 

 
 

4. The screen refreshes and permission levels are displayed.   
In the example below, Power Users settings were changed from Full Control to Manage 

Hierarchy.   
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Add Users to Groups 
Full Control users that are added as a ‘Group Owner’ have the ability to add users to a SharePoint group.   

1. Click Site Actions then Site Settings 

 ,   

2. The Site Settings window opens 

3. Click Users and Permissions  
4. Select the Group to add users 

 The ‘Members’ group is selected for this example 
 

 
 

5. Click New and then Add Users  
6. You can add users names to the Users/Groups section by Check Names or Address Book 

Check Names 

A. Enter the user’s name and click the Check Names icon. 
a. Multiple users can be added at the same time  

B. Validation is complete when the name is underlined and a semicolon displays between each 
name. 

a. Note:  If the user name is entered incorrectly, an error message displays.  If the name is 
close to matching a name in the system you can click on the name and a list displays to 
choose a user from. If the name is not similar to another in the system you will have to 
delete the entry and reenter the user name and try again.   
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Address Book 

A. Click the address book 

 

B. Enter the user’s name, press Enter 
C. Click on user’s name, click Add 

a. Multiple users can be added at the same time 
D. All user names appear in the Add field 

a.   
E. Click OK   

 
Note:  In this example, Tanya Davidson has already been found and selected.  Mike Acord is 

currently being searched for and the results are displayed. 

 

7. Continuing from Step 6 above: Send E-mail option:  Default is checked 

 Users receive an email notification with a link to the site 

 Uncheck box to avoid sending  an email notification to users 

 

8. Click OK 
 



              

Page 26 of 63 
 

 Full Control User Training 
 

9. Verify that the user was added to the group 

 

Remove Users from Groups 
When a user leaves an organization, the user account is not removed from the SharePoint group.  The 

person responsible for maintaining the group will need to remove the user from the group.   

1. Click Site Actions then Site Settings    
2. The Site Settings window opens 
3. Under the Users and Permissions heading, click People and Groups  
4. Under the Groups section, click the group 
5. Select users to remove from group 

 
 

6. Click Actions then Remove Users from Group  
7. Confirmation message displays.   

 
8. Click OK 
9. Screen refreshes and users are removed from group 
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Delete a User Group  
Full Control users can delete a user group if the user is added as the owner of the group. 

1. Click Site Actions then Site Settings 

,  
2. Under the Users and Permissions heading, click People and Groups 

 
3. Click Power Users> Settings>Group Settings 

 

4. Scroll down, click Delete 

 
5. Confirmation message displays.  

 
6. Click OK 

Set Unique Site Permissions 
Full Control users can change a site’s permissions so it has different (unique) permissions than the 

parent site.   

1. Click Site Actions then Site Permissions 
2. Click Stop Inheriting Permissions 

The yellow bar contains a message that the site inherits permissions.   

 

3. Confirmation message displays. 
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4. Click OK 
5. Select the user groups to remove 
6. Click Remove User Permissions 

The yellow bar contains a message that the site has unique permissions.   

 

7. Confirmation message displays.   

 
 

8. Click OK  
9. User groups are removed 

Check Site Permissions 
Full Control users can check permissions to sites and lists.  The instructions below are to check site 

permissions.   

1. Click Site Actions then Site Permissions 

 ,  
2. Click Check Permissions 

 
3. User/Group:  Enter user or group 

 Click the address book icon  to lookup the user or group in the address book 
4. Click Check Now 

 In example below, results for user group permissions are None 
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Access Requests  
SharePoint allows users to request access to the site.   

1. Click Site Actions then Site Permissions   
2. Click Manage Access Requests 
3. Access Request Settings:  Default is shown below 

 Only one email address can be added 

 An Outlook Distribution List can be added instead of a user’s email so multiple users can 
receive the request. 

4. Click OK 
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Practice Activities 
Before continuing the training, practice what was covered in the Site Security section by completing the 

practice activities.   

Practice:  Create a User Group  

Refer to Table of Contents        Time:  10 min 

1. Go to the site created using a site template (Practice 2) 
2. Create a user group 

 Name:  Use your initials and last name   Ex:  TMDavidson 
3. Give the group Contribute permissions 
4. Add five users to the group 

 Do not send the users an email notification message 
 

Practice Notes: 

 

 

 

Practice:  Change Group Permissions  

Refer to Table of Contents        Time:  5 min 

1. Go to the site created using a site template (Practice 2) 
2. Change the permissions for the user group to Read 

 
Practice Notes: 

 

 

 

Practice:  Remove Users from Group  

Refer to Table of Contents        Time:  5 min 

1. Go to the user group (Practice 6) 
2. Remove two users from the group  

 
 

Practice Notes: 
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Lists 
Most content stored in SharePoint is stored in lists.  SharePoint calendars, document libraries, custom 

lists, and surveys are lists.  A list is a container that stores similar information in a structured format. A 

document library is a specialized type of list that contains a collection of files, usually Microsoft Office 

documents.  

Types of Lists 
Below is a description of commonly used lists.   

Create a List  
The steps involved for creating a list may vary slightly based on the type of list you choose to create.  For 

example, Calendars will show the Calendar Tools tab on the ribbon while a custom list will show the List 

tab.  In the example below, a Custom List is created. 

1. Click Site Actions  then More Options ,  

2. Filter By: List  
3. Click   Custom List  
4. Name:  Enter name 
5. Click More Options  

 
6. Name and Description windows displays 

 Description: optional 

 Navigation:  Default is Yes 

 Link displays in the Quick Launch area 
 

 

 

 

List Description 

Announcements Post important announcements or news items and statuses.   

Calendar A calendar of upcoming meetings, deadlines or other events.  Calendar 
information can be synchronized with MS Outlook. 

Custom List A blank list to which you can add your own columns and views.  

Discussion Board Discussion boards make it easy to manage discussion threads and it can 
be configured to require approval for all posts. 

Links A list of web pages or other SharePoint resources. 

Survey Create surveys/evaluations for people to answer and view graphical 
summaries of the responses. 
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7. Click Create 

Add Columns (Metadata) 
Full Control users can add columns to lists to collect additional information or display specific data.   

1. Go to list, click on List Tools >List Tab> Create Column 
2. Enter the column name 

 Choose the format type 

 
 

Column Type Description 

Single line of text Use for textual information, including numbers, punctuation, and symbols 
without carriage returns.  Maximum number of characters: 255 

Multiple lines of text Use for multiple lines of textual information with no maximum length.  
May contain a Rich Text editing toolbar. 

Choice Use for a list of choices.  Examples could include state, status, and 
department.  User can determine how the choices are displayed by 
selecting a display type from optional settings. 

Number Use for numerical data, including percentages.  SharePoint does not allow 
letters or symbols in this column type.   

Currency Use for monetary values.  Examples include cost, salary, and payment. 

Date and Time Use for date values or both date and time.  This column cannot display 
only the time. 

Lookup Use for a list of choices for user to select from.  Difference between 
Choice and Lookup, lookup determines the choices dynamically by 
presenting the values from another list on the same site.  

Yes/No Use for Yes/No values.  Displays as a check box. 

Person or Group Use for Person or Group type within the organization.   

Hyperlink or Picture Use when the column should contain a link to another URL or an image 
that should be displayed with the list item. 



              

Page 33 of 63 
 

 Full Control User Training 
 

Column Type Description 

Calculated Use when the column should not allow users to determine the value, 
instead it should calculate the value based on a formula that can include 
other list item column data. 

External Data Use to add data from external business applications to the list.  Contact 
the SharePoint administrator for more information. 

Managed Metadata Available only with SharePoint Server 2010.  Use for creation of nested 
hierarchical trees of terms.   Contact the SharePoint administrator for 
more information. 

 
3. Additional Column Settings:  Default settings are shown 

 
 

4. Column Validation (optional):  Allows user to add validation formula and a user message 
5. Click OK 

Create a New View 
Full Control users can select columns to show or hide columns and specify the order of the columns for a 

list.  In the following example, instructions are shown for a custom list.  These instructions can also be 

used for a library or other types of lists. 

Note:  If the Title field is removed from a view, a drop-down menu does not appear when users hover 

on the list item and users will have to use the ribbon menu to interact with the item.   

1. Go to the list, click on List Tools> List Tab 
2. Click Create View 
3.  Select  Standard View 
4. Enter a name for the View 

 Select checkbox to make it the default view 

 
 

5. View Audience:  Default is shown below 
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6. Columns:  Uncheck/Check columns to Display 

 Position from Left: Change the order the column displays in view 

 

7. Sort: Select up to two columns to determine the order in which the items in the views are 
displayed 

 Default view is shown 

  
  

8. Filter:  Use to display a filtered view.  Default is shown. 
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9. Inline Editing: Use to display an Edit button  on each row. 

 Select Allow inline editing 

 
 

10. Tabular View:  Default shows the checkboxes.   

 Uncheck to remove checkboxes 

 

Without checkboxes     With checkboxes 

   

11. Group By:  Select up to two columns to determine what type of group and subgroup the items in 
the view will be displayed in. 

 
 

12. Totals:  Select one or more totals to display. 

 

13. Style:  Change the style of the list.   
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14. Folders:  Default shows items inside folders. 

 

15. Item Limit:  Changes the number of files displayed on page.  When there are a large number of 
files, adjust size to 100 or higher, so more files appear on the page.     

 

16. Mobile:  Adjust mobile settings for this view. 

 

17. Click OK 

Change List Permissions 
Full Control users can set unique permissions for a list.   

1. Go to the list, click on List Tools – List Tab 
2. Click List Permissions  
3. To stop inheriting permissions, click Stop Inheriting Permissions  
4. Notification message displays.   
5. Click OK  
6. Select the user group, click Edit User Permissions or Remove  User Permissions 

 Edit User Permissions:   

 Select the new permission level and click OK  
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Inherit Permissions 

To change permissions back to the original inherited permissions. 
1. Go to the list, click on List Tools>List Tab 
2. Click List Permissions then Inherit Permissions  
3. Notification message displays.  
4. Click OK 
5. Yellow banner displays message indicating permission are being inherited. 

 

Managing Lists 
Full Control users can manage a list’s settings by clicking List Tools – List tab, List Settings.  Other lists, 

such as the Library list, can be managed using Library Tools – Library tab.   

General Settings 

Full Control users can change a list’s title, description, and navigation.   

1. Go to the list, click on List Tools > List Tab> List Settings  
2. Under the General Settings heading, click Title, description and navigation. 
3.  Make desired changes then click Save 

 

Enable Versioning 

SharePoint offers versioning for lists.  When versioning is enabled, SharePoint saves a copy of the list 

item whenever the user makes changes to the list item.  Only the current version of the list item is 

shown in views. The user has to open version history to view previous versions.  The instructions below 

are for enabling versioning for a document library. 

1. Go to document library, click on Library Tools >Library Tab>List Settings  

2. Under the General Settings heading, click Versioning Settings   
3. Document Version History:  Default is No versioning  

 Select ‘Create major versions’ or ‘Create major and minor (draft) versions’ 

 If a version limit is not set, SharePoint saves all versions 
 

Note:  Full Control users need to determine how many versions to retain.  A version is saved 
every time a user updates the list item.     
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4. Click OK 
 

Workflows 
SharePoint 2010 has a collaboration tool called a ‘workflow’ that provides Full Control users the ability 

to execute defined business processes.  SharePoint 2010 Server has many types of workflow templates 

to choose from, and SharePoint 2010 Foundation has only the Three-state workflow.  This training 

provides basic information about the Three-state workflow.   

The Three-state workflow is a programmable interface that can be setup to assign tasks, send email 

notifications, and track the status of a list item through three states (phases): Not Started, In Progress, 

and Finished.  Before using the workflow, the user must set up a list to use the workflow.  In the 

example below, the Issue Tracking list template is used to work with the workflow.     

Note:  A list can be used with the Three-state workflow as long as it contains at least one Choice column 

that includes three or more choice values.  When setting up the workflow, the user must specify the 

Choice column that contains the state values for the workflow to track.   

Add a Three-State Workflow to a List 

1. While viewing the list you want to add the workflow to: Click List Tools > List tab>Workflow 
Settings 

  
2. In the dialog that displays, select All for “These workflows are configured to run on items of this 

type” 
3. Click Add a workflow 

 
4. Select a workflow template:  Click Three-state 

 The example below shows SharePoint 2010 Server workflow templates 
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5. Name:  Enter name 

 
 

6. Select a task list:  Select Tasks or New task list 

 
 

7. Select a history list: Default is selected 

 
 

8. Start Options:  Specify how the workflow can be started 

 

9. Click Next 
10. Workflow states:  Select a ‘Choice’ field 

 The example shown is for an Issue Status 

 

11. Task Details Section:  Specify actions when the workflow is initiated  
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 Specify actions when the workflow changes to middle state 

   

12. Click OK 

Edit the Workflow Settings 

1. Go to the list, click List Tools >List tab>Workflow Settings  
2. Click the Workflow Settings arrow  
3. Under Workflow Name, click Workflow Name 

 
 

4. Make necessary changes 

5. Click OK  
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Practice Activities 
Before continuing the training, practice what was covered in the List and Library Management section by 

completing the practice activities.   

Practice:  Create and Manage a List  

Refer to Table of Contents        Time:  10 min 

1. Go to the Training Sandbox site  
2. Create a list (any type but a library), do not show on Quick Launch 
3. Add two columns to the list, make them required fields 
4. Change the  title and show list on the Quick Launch 

 

Practice Notes: 

 

 

Practice:  Create a New View  

Refer to Table of Contents        Time:  10 min 

1. Go to the list (Practice 8)   
2. Create a new view  
3. Display columns created in Practice 8 

 

Practice Notes: 

 

 

Practice:  Enable Versioning  

Refer to Table of Contents        Time:  10 min 

1. Go to the list (Practice 8)   
2. Enable major versioning for the list  

 

Practice Notes: 
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Libraries 
There are different types of libraries that Full Control users can create.  This training covers Document 

and Picture libraries.   

Create a Document Library 
1. Click Site Actions then New Document Library 

,  
2. Name and Description:  Enter name 
3. Description: optional 

 
 
 

 

 

 
4. Navigation:  Default is Yes 
5. Document Version History:  Default is No 
6. Document Template:  Microsoft Word document 

 
 

7. Click Create. The  processing message displays    

Create a Library Template 
Full Control users can create a library template that contains the same configuration of a specific library.  

Using a library template to create a library is helpful when Full Control users need to create multiple 

libraries with the same structure.   

1. Go to library (for template) 
2. Click Library Tools > Library tab>Library Settings.  
3. Under the Permissions and Management heading, click Save document library as template. 
4. File name:  Enter name 

 This file name is stored in the Site Gallery template. 
5. Template name:  Enter name 

 The template name and description appear as a selection when creating a new library. 
6. Include Content:  Check to include all documents in the library 
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7. Processing message displays, library is created 
8. Click Browse tab to view the library name 

Change Library Permissions 
Full Control users can control access to a library by setting unique permissions.   

1. Go to library (for unique permissions) 
2. Click Library Tools > Library tab>Library Permissions  
3. Click Stop Inheriting Permissions 

Note: The yellow bar contains a message that the library inherits permissions.   
 

 
 

4. Permissions message displays, click OK 

 
 

5. Screen refreshes and shows the library has unique permissions 
6. Check the box to remove user(s), click Remove User Permissions 
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7. Remove permissions message displays, click OK 

 
 

Grant Permissions 

1. Go to library 
2. Click Library tools> Library tab>Library Permissions  
3. Click Grant Permissions  
4. Users/Groups:  Enter user names, group names, or email addresses.  Separate user names with a 

semicolon. 
5. Grant Permissions:  Default is Grant users permission directly, select the permission level 

 
 

6. Send Email:  Default is checked  

 Type personal message 

 
 

7. Click OK 

Inherit Permissions 

When a library is given unique permissions, it is easy to change the library’s permissions to inherit from 

the parent site. 

1. Go to library   
2. Click Library tools >Library tab>Library Permissions 
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3. Click  
4. Inherit permissions message displays. 

  
5. Click OK 

Upload Documents to Library 
Contribute and Full Control users can upload a single document or multiple documents at a time. 

Upload a Single Document 

1. Click Add Document    
2. Click Browse;  select a file  
3. Click OK 

Note:  Users can change their destination folder by clicking ‘Choose Folder’. 

 

 

Upload Multiple Documents 

Drag and Drop Option:   

SharePoint allows users to drag and drop multiple files into the Upload Multiple Documents window.   

1. Click Add Document > Upload Multiple Files   
2. Drag and drop selected files  

 
 

3. Click OK 

Browse Option:  

SharePoint allows users to browse and select multiple files to include in the Upload Multiple Documents 

window.   
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1. Click Add Document then Upload Multiple Files. >  
2. Click Browse. The file selection dialog box will open. 

  
3. Click OK 

Create a New Document 
One of the unique features of SharePoint is users can upload documents to a library and create new 

documents from the same space.  When Contribute and Full Control users create a document within a 

library, it is automatically stored in the library.   

1. Go to the Library 

2. Click New Document,  New Document 

 
 

3. Open message displays, click OK 

 
 

4. Enter a file name and click Save 
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Require Check Out 

Full Control users can configure a document library to require users to ‘Check Out’ a document before 

editing it.   

1. Go to the library 
2. Click Library Tools >Library tab>Library Settings  

3. Click Versioning settings   
4. Scroll down to Require Check Out, select Yes 
5. Click OK 

Creating a Document Content Type  
Full Control users can configure document templates to a document content type.  When a user clicks 

the New button on the ribbon of an out of the box document library, a blank Word document is shown 

as the only choice.  When an organization wants users to complete a specific form that has been created 

(Word document, PDF, InfoPath), a template can be added to the library so when a user clicks on the 

template, a new form opens every time.     

1. Upload the document template as a content type to the site collection:   

 Click Site Actions  then Site Settings   
2. Under Galleries click Site content types  
3. Click Create  
4. Name and Description:   

 Name:  Enter name  

 Description:  The description will be shown on the new button 
5. Parent Content Type:   

 Select parent content type from:  Select Document Content Types 

 Parent Content Type:  Select Document 
6. Group:  Put this site content type into: 

 Existing group:  Select Custom Content Types 
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7. Click OK 

 
8. The Site Content Type Information screen displays, click Advanced Settings   
9. Document Template:  Default is Enter the URL of an existing document template 

 Use this option if template is already stored on SharePoint 

 If document is stored on network drive or computer, choose Upload a new document 
template 

 

10. Read Only:  Should this content type be read only? Default is No 

 Keep the default setting so the file can be modified if needed 

 
 

11. Update Sites and Lists:  Update all content types inheriting from this type? Default is Yes 

 
 

12. Click OK 
13. Go to the library 
14. Click Library Tools> Library tab>Library Settings  
15. Click Advanced Settings  
16. Content Types:  Select Yes 
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17. Click OK 
18. Scroll down to Content Types 
19. Click Add from existing site content types  
20. Click on arrow, select Custom Content Types,  choose the document template, click Add 

 
 

21. The template shows in the Content Types area 

 
 

22. Go to the library, click Documents tab > New Document  
23. Choose the template 

 
 

24. Contribute and Full Control users can Save As and store the document in the library or other 
location 

Delete a Library 
Full Control users have the ability to delete a document library.   

1. Navigate to library to delete 
2. Click Library Tools > Library tab> Library Settings  
3. Under Permissions and Management, click Delete this document library 
4. Delete confirmation message displays, click OK 

 
 
Note:  The deleted library is stored in the Recycle Bin for 30 days (default setting).   
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Practice Activities 
Before continuing the training, practice what was covered in the Library section by completing the 

practice activities.   

Practice:  Create a document library  

Refer to Table of Contents        Time:  10 min 

1. Create a document library 
2. Require users to Check Out the document 
3. Give the document unique permissions  

 Do not delete users 
4. Make the document library a template  

 

Practice Notes: 

 

 

Practice:  Upload and Edit Documents  

Refer to Table of Contents        Time:  10 min 

1. Upload documents to the library  

 Choose Multiple Upload 
2. Edit the document 

 Save changes 

 Make sure others can see your changes 
3. Make the document library a template  

 

Practice Notes: 

 

 

Practice:  Delete a Library  

Refer to Table of Contents        Time:  10 min 

1. Go to the library created in practice 11 
2. Delete the library  

Practice Notes: 
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Pages 
There are three different types of pages on a SharePoint site: system, wiki, and web part pages.  Users 

can add wiki and web part pages.   

System Pages 
A system page contains tools that allow a user to create or configure a list, but a user cannot change the 
page.  Below is an example of the All Site Content system page. 
 

 

Wiki Pages 
Wiki pages are the easiest pages for users to change since it provides an editor very similar to Microsoft 
Word.  Every section of the wiki page can be modified to include text, images, links, lists, and web parts.  
Wiki pages are the default page type in SharePoint 2010 team sites.  The home page of a Team Site is an 
example of a Wiki Page. 

Add a Wiki Page 

Wiki pages are easy to create and edit, but users should know this before trying to copy/paste content 

into a page:   

1) Users cannot copy/paste a picture from a document (see Insert a Picture) 
2) Word formatting does not transfer into the wiki page (see Format a Wiki Page) 

 
SharePoint stores all wiki pages in the Site Pages library.   

1. Click Site Actions then  New Page  

 Loading message displays and New Page window opens 
2. Enter a page name, click Create 
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Note:  The page is created and a user can enter content on the page.  Click the Browse tab to 
verify the page name being edited.   

 
 

3. Enter a header and content 

 
 

4. There is more than one way to save the page: 

1) Save and Close: click   or Save & Close  
~OR~ 
2) Save and Keep Editing: click  Save & Close or Save and Keep Editing 

 

Note:  Choose Stop Editing  to stop editing the page.  Save Changes message 

displays, select Yes, No, or Cancel.   

Edit a Wiki Page 

1. There are two ways  to edit the wiki page:   

1) Click  (next to Browse tab) 
~OR~ 
2) Click Site Action then Edit Page                           

 
Note:  The text editor ribbon launches and the cursor displays at the top of the page 
 

2. Type the information or copy/paste special into notepad, then copy/paste into a wiki page and 
format as necessary.   

  
 
Note: Basic edit functions are identified on the ribbon  

 
3. Make changes to the page: click Save & Close    

Format a Wiki Page 

Wiki pages use Rich Text Formatting (RTF), which provides similar formatting functions as Word.  When 

a user tries to copy/paste content from a MS Word document, it affects the formatting of a wiki page.   
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In the picture below, the information from ‘Edit a Wiki Page’ (previous section), was pasted into a wiki 

page.  Notice that the line spacing, indentations, and font size formatting were not transferred to the 

wiki page.   

 

The page formatting will not look the same if a user initially types on the page, then pastes Word 

content (bullets, pictures, headers) on the page.   

Clear Format 
The clear format option will page clear all formatting from the selected area, leaving only plain text.   

1. Highlight content, click   
2. Save the page 

 Try this alternate method to clear the format:  Delete the text (if any), select the empty 
space, and click Clear Format. 

Insert a picture on a Wiki Page 

It is easy for Contribute and Full Control users to insert a picture on a page. 

1. Click  (next to Browse tab) 
2. Place cursor on page 
3. Click Editing Tools>Insert>Picture 

    
4. Browse for the picture, click OK 

 
Note:  Pictures are stored in the Site Assets library. 

5. Site Assets window displays, click Save 
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Move the picture 
Select the picture and drag to another area on the page or use cut/paste.   
 
Resize the picture 
There are two ways to resize a picture: drag the top corner and using the picture tools tab. 
 

1. Drag the Top Corner:  

 Resize the picture by clicking and dragging the corner box to the desired size 

 Click Save or Save and Keep Editing. 

 
 

2. Picture Tools tab:   

 Click on the picture (Picture Tools tab displays) and click Design  

 Enter Horizontal Size (pix)  

 This quickly makes a consistent size  

 Click Page tab, Save and Keep Editing 

Insert a Link on a Wiki Page 

Contribute and Full Control users can convert text into a link.  These instructions are different than 

adding a link web part to a page. 

1. Capture the link of the URL (highlight the address bar)  or SharePoint document (right click on 
Word icon, copy shortcut), go back to wiki page 

2. Click  (next to Browse tab) 

3. Type the text and highlight it   
 

4. Click Insert >Link 
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5. Type or paste in address, click OK 

 
 

 Note:  Address must have http:// or https:// 

6. Enter a description (optional) – the description shows when a user hovers on the link 

Add a link on a Wiki Page using [[  ]]  

Contribute and Full Control users can add links to wiki pages that link to other wiki pages stored in the 

Site Pages library.      

1. Click  (next to Browse tab) 
2. Put cursor where to add the link, type [[ 
3. Menu displays with existing wiki pages or option to select a list 

 

4. Select a page and press enter – OR –  type a name (for a new page) 

 For a new page: Type ]] after the name (no spaces) 
Example:  [[Training Procedures]] 

5. Click Save & Close to test the link 
a) New pages that have not been created have a broken underline 
b) Click on the name to create the page 

 
c) Click Create  
d) Enter content, click Save & Close 

Use the | to change display name 

Use the | (pipe symbol) to add a wiki link to a word in a sentence instead of adding the actual page 

name.  To change the wiki page name displayed in a sentence. 

1. Type [[page name|enter display name]] 
Example: In the example below, the name of the page is Training, the name to display is 
immediately after the | symbol. 
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Insert a List link on a Wiki Page 

1. Click  (next to Browse tab) 
2. Put cursor where to add the link, type [[ 
3. Select List from the menu that displays  
4. Select a list and press Enter 

 
 

5. SharePoint adds a /, type ]]   
6. Click Save & Close and click the link to test it 

 Organize the links.  In the example below, a bulleted list looks organized and it is easier 
to read.   

   
 

Upload a File and Insert a Link 

Contribute and Full Control users can upload a file and add a link at the same time.   

1. Click  (next to Browse tab) 
2. Put cursor where to add the link, click Insert tab then Upload file  
3. Browse for file, select where to upload, click OK 

 
4. Properties window displays, make any adjustments 
5. Click Save and click Save & Close 
6. This is the view of an uploaded file link 

 
7. To  remove the file type log:   

 Highlight the link, click Link Tools – Format on ribbon 

 Uncheck the box by Display Icon then click Save & Close 

 Changes the view to 
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Change the layout 

Contribute and Full Control users can change the text layout for wiki pages.   

Note:  Users cannot change the web part page layout.      

1. Click  (next to Browse tab) 
2. On the Format Text  tab, click Text Layout  
3. Select a layout 

 
 

Below is an example of a 3-column layout              

 

Note: To undo any changes, press Ctrl Z or Undo  
4. Click Save and Close    

Web Part Pages 
Web Part Pages 
Web part pages are great for displaying data, but more complicated for users to edit the web part pages 
because of pages have designated layout zones and must be constructed by placing web parts on the 
within those zones.  

Differences between wiki and web part pages 

Wiki pages  
Wiki pages contain an Edit button next to the 
Browse tab.  Also, click Site Actions, the message 
is different than the web part pages message. 
 

Web part pages  
Web part pages do not have the Edit button next 
to the Browse tab.   
To edit the page: click Site Actions, Edit Page.   
 

Tip:  Save Options 

Click the Save & Close arrow to view 

the save options 
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There are many types of web part categories.  This training covers the ‘Lists and Libraries’ and ‘Media 

and Content’ web parts.   

In the example below, there are eight web parts for the category ‘Lists and Libraries’ each representing a 

corresponding list or library within the site.  Before a user can add a list or library web part to a page, 

the list or library has to exist on the site.  For example, if a Full Control user deleted the Announcements 

list and clicked Insert > Web Part, the Announcements web part would not show as an option (see 

picture below).   

 

Add a List and Libraries Web Part 

Contribute and Full Control users can add lists (document library, calendar, and links) on a page by 

adding list web parts.   

1. Click  (next to Browse tab) 
2. Click Insert tab>Web Part  
3. Under the Categories section, click Lists and Libraries   
4. Under the Web Parts section, select a web part  

 

5. Add Web Part to: Rich Content is default, click Add 
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6. Loading message displays 

  
  

7. When loading is complete the web part displays on the page 
8. Click Save & Close  

Add a Media and Content Web Part 

Contribute and Full Control users can choose from the following Media and Content web parts: 

Web Part Description 

Content Editor Allow users to enter rich text content 

Image Viewer Placeholder to display an image 

Media Web Part Placeholder for video and audio  

Page Viewer Allows users to display another web page within this web page 

Picture Library Slideshow  Display a slideshow of images from a picture library 

Silverlight  Display a Silverlight application 

 

1. Click  (next to Browse tab) 
2. Click Insert tab> Web Part,  

3. Select Media and Content    
4. Select a web part 
5. Click Add 
6. Web part displays on page, click Save & Close  

Configure a Web Part 

Contribute and Full Control users can change the appearance of the web part by modifying the 

properties.  The property sections shown in each web part may differ; it depends upon the type of web 

part that is edited.  For example, the Image Viewer web part has an Image Link section compared to a 

Calendar that has a List Views section.  All web parts have a title and border section and the properties 

can be changed so the title is renamed, hidden, and borders can be added.   
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1. Click  (next to Browse tab) 
2. Click on the  arrow to expand the list and select Edit Web Part 

 

3. Toolbar Type: Select Show Toolbar   

 
 

4. Click Appearance to expand the menu 
5. Enter new title in the Title field 

  
 

6. Scroll down to Chrome Type 
7. In the Chrome Type drop down list select Title Only 

 
 

8. Click Apply  to see the changes and keep the edit view open 
9. Click OK 

 
In the example below, a Calendar web part was modified.  The After picture shows the new title and 

toolbar. 

Before               After 

 

Tip:  Chrome Type 

Try each chrome type to see 

which view looks best.   



              

Page 61 of 63 
 

 Full Control User Training 
 

  

 

Delete a Web Part 

Users may decide a web part no longer needs to be displayed on the page.  Deleting a web part removes 

the web part from a page; it does not delete the list.   

1. Click  (next to Browse tab) 
2. Click on the down-arrow 
3. Select Delete 

 
4. A Deletion Confirmation Message displays.   

 
5. Click OK (the page refreshes) 
6. Click Save & Close 
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Practice Activities 
Practice what was covered in the Web Parts section by completing the practice activities.   

Practice:   Add a Wiki Page 

Refer to Table of Contents        Time:  15 min 

1. Go to the sub-site created in practice 1 
2. Add a wiki page 

 Give the page your Name 

 Add a heading with a larger font and different color 

 Add content related to your department or your credentials 
 

Practice Notes: 

 

 

Practice:   Insert a Picture on Wiki Page 

Refer to Table of Contents        Time:  10 min 

1. Go to the wiki page added in practice # 
2. Insert a picture on the page 

 
Practice Notes: 

 

 

 

Practice:   Add a Web Part 

Refer to Table of Contents        Time:  10 min 

1. Go to the sub-site created in practice 1 
2. Add a list web part to the main page 

 Lists include a calendar, links, and library 
3. Rename the list and display the heading with a full toolbar 

 

Practice Notes: 
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Practice:   Delete a Web Part 

Refer to Table of Contents        Time:  10 min 

1. Go to the sub-site created in practice 1 
2. Delete the web part that was added in the previous activity 

 

Practice Notes: 

 

 

 


